WordPress 5.5 开始支持主题的WP和PHP最低版本标头检测

PHP和WordPress版本检查即将进入WordPress主题系统。该功能三天前被引入了WordPress核心。这将阻止最终用户安装或激活与其当前版本的PHP或WordPress不兼容的主题。更改预计将在WordPress 5.5中进行。

长期以来,此功能一直存在于许多主题作者的愿望清单中,尤其是PHP版本检查。插件作者从WordPress 5.2开始获得了PHP版本限制的能力。但是,主题作者却迟迟没有等到该功能。

以前,用于在各个主题内手动处理版本检查的代码比在插件中更复杂。主题作者需要在主题切换后运行兼容性检查,并使用两种不同的方法来阻止自定义程序中的主题预览,具体取决于用户的WordPress版本。

在安装并尝试激活主题之前,用户没有真正的方式知道主题是否可以在其站点上使用。所有的版本检测功能,只有在启用主题后才会触发,有时候启用主题后会导致网站崩溃,带来了很不好的用户体验。

到目前为止,还没有一种机制可以让用户知道他们需要升级PHP才能使用特定主题。

一些主题作者可能会选择继续支持旧版本的PHP(例如5.6),以扩大潜在的用户群。但是,想要切换到较新功能的开发人员现在可以在核心平台的支持下去实现。

所以,从WordPress 5.5 版本开始,将可以通过主题标头信息去读取该主题的兼容数据,如果用户的WP或PHP版本不达标,就无法启用和预览主题。

对用户的影响

浏览WordPress主题目录的用户可能会开始注意到可用于某些主题的新信息。与插件类似,访问者应该会看到针对某些主题列出的WordPress版本和PHP版本。例如,“ Twenty Twenty”主题现在列出了以下最低要求:

  • WordPress版本: 4.7或更高
  • PHP版本: 5.2.4或更高

并非所有主题都会列出这些数字。用填充这些字段所需的数据更新旧主题需要一些时间。

在WordPress 5.5中,主题的管理界​​面将有所更改。尝试安装或激活主题时,如果用户搜索的主题不兼容当前用户的WordPress或PHP版本,安装按钮将替换为禁用按钮,显示为“无法安装”。如果已安装主题但未激活,则激活链接也会被替换为“无法激活”按钮。用户也无法实时预览不兼容的主题。

该功能在 外观-自定义 界面中与在WordPress后台通过主题屏幕的功能相同。

对主题作者的影响

WordPress主题团队最近宣布了两个新的必需标头,供WordPress主题开发者放置在主题的style.css文件中。第一个必填字段是Tested up to,这是主题经过测试的WordPress的最新版本。第二个Requires PHP字段是主题支持的最低PHP版本。

目前尚不清楚团队为何决定要求这两个字段,但不要求Requires at least字段,它代表所需的最低WordPress版本。主题作者很可能希望将三个标头都放置在主题中。

正确的做法字段示例如下:

/*
Theme Name: Twenty Twenty
Text Domain: twentytwenty
Version: 1.3
Tested up to: 5.4
Requires at least: 4.7
Requires PHP: 5.2.4
*/
  • Tested up to:已测试兼容的最新WP版本
  • Requires at least:所要求的最低WP版本
  • Requires PHP:所要求的最低PHP版本

请注意,只有当用户使用 WordPress 5.5或以上版本时,以上参数才可以正常工作,所以,作为主题开发者,你仍需保留以前所用的版本检测功能,以便兼容低版本的WP。

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。
欢迎关注我们的微信公众号:WPDAXUE

倡萌

一个文科IT宅男,喜欢折腾WordPress和被它折腾 ^_^

暂无评论

发表评论