新安装WordPress遇到syntax error, unexpected ‘.’, expecting ‘&’ or T_VARIABLE 的解决办法

最近有几个朋友问过我这个问题,新安装WordPress遇到如下错误提示:

Parse error: syntax error, unexpected '.', expecting '&' or T_VARIABLE in /data/home/syu7****001/htdocs/wp-includes/functions.php on line 1064

出现这个问题的根源在于,你的PHP版本低于 5.6.20 导致的,比如阿里云虚拟主机,默认开启的PHP版本是 5.4,而从WordPress 5.2版本开始,就强制要求PHP版本必须在 5.6.20 以上才可以正常使用

知道问题所在,解决起来就比较容易了,在你的主机管理面板去找到切换PHP版本的选项,建议选择 PHP 7.2+。比如阿里云虚拟主机,可以在主机管理界面-高级环境设置-PHP版本下切换到 php7.2,保存即可:

如果你使用的主机不支持php 5.6.20以上,那就联系主机商寻求帮助。

倡萌

一个文科IT宅男,喜欢折腾WordPress和被它折腾 ^_^

暂无评论

发表评论