如何解决升级到WordPress 5.5后导致js报错和网站功能不正常

有些朋友可能会发现,升级到WordPress 5.5以后,网站的某些功能不正常了,通过浏览器调试工具查看,会发现一些js报错,比如 提示js函数 .live 不存在之类的。

其实主要的原因是,正如《WordPress 5.5 正式版发布》提到的:

WordPress 5.5删除了jQuery Migrate1.x。对于使用jQuery的开发人员来说,这是一个问题。如果使用jQuery,请确保您不依赖jQuery Migrate 1.x单独提供的任何功能。

也就是说,有些主题或插件使用了比较老旧的jQuery函数,以前一直都采用jQuery Migrate1.x做兼容处理的,但是现在WordPress 5.5+ 默认禁用了这个兼容库,所以就出现问题了。

对于开发者来说,应该尽快更新自己的产品代码,尽可能使用新的jQuery函数。解除对jQuery Migrate1.x的依赖。开发者指南

对于大多数的普通用户来说,肯定是无法去自己修改代码做兼容处理的,怎么办?

其实WordPress官方团队早就想到了这个问题,专门开发了一个小插件 Enable jQuery Migrate Helper,只需要安装和启用插件,就可以继续加载 jQuery Migrate1.x,让你的网站避免出现js错误。

不过,建议普通用户可以联系一下主题和插件作者,提醒他们更新代码,这样才是最好的做法。

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。
欢迎关注我们的微信公众号:WPDAXUE

倡萌

一个文科IT宅男,喜欢折腾WordPress和被它折腾 ^_^

暂无评论

发表评论